The upcoming Apache Camel 2.17.0 release, which we plan to release later this month be end of next week if all goes well, will be the last release that supports Java 1.7.
In the following release Apache Camel 2.18, Java 1.8 is required.  We will change the source compiler settings to be --source 1.8 and --target 1.8.

All Camel components that do not work on Java 1.8 will likewise be dropped.

A rule of thumb to remember which Camel version support which Java version is easy, because the numbers align very well:

  • Camel 2.17.x = Java 1.7.x
  • Camel 2.18.x = Java 1.8.x

 

© 2004-2015 The Apache Software Foundation.
Apache Camel, Camel, Apache, the Apache feather logo, and the Apache Camel project logo are trademarks of The Apache Software Foundation. All other marks mentioned may be trademarks or registered trademarks of their respective owners.
Graphic Design By Hiram